Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2012
    Posts
    7

    Default OZ Tower Base alignment issue

    Hello all....have a 2013 Outback V....love the boat but I've had tower issues from the day it was dropped off. The tower base on the starboard side isn't aligned correctly and the quick release fastener is cross threading...dealer said he was going to take care of it but nothing has been done yet....last time we communicated he said Moomba may "redesign" the base and that's the delay. Anyone else had an alignment problem with the Oz Tower and if so what was done about it?

    Thanks all!

  2. #2
    Join Date
    Jun 2013
    Location
    Naperville, IL || North Scott Lake, MI
    Posts
    590

    Default OZ Tower Base alignment issue

    I had somewhat the same prob but not quite as bad. I was able to work around it by putting up the starboard side first and moving it around a bit to get the alignment right and then do the port side last.
    2013 Outback V
    2003 SeaRay 182 -- gone but not forgotten...

  3. #3
    Join Date
    Oct 2008
    Location
    Arkansas
    Posts
    614

    Default

    I had to get a replace and it was different then original. The new one I got, the thru deck bolts were tightened into the base and the only way to tighten it was from the bottom. It made lining it up a lot easier.

    Did help lining up the original one where the thru bolts went thru the tower base and you had hold the bolt on the top to tighten with the tower folded. They were loosely snugged, raised the tower, then from the bottom used a vise grip to hold the bolt and used a ratcheting wrench to tighten the nut.

    I also keep anti-seize lubricant on the tower knob bolt.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •