Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Hybrid View

  1. #1
    Join Date
    Jan 2009
    Location
    Salem, OR
    Posts
    110

    Default Ballast continues to fill

    I've had my 08 LSV for 5 summers and have ran into my first issue with ballast. My right ballast fills no matter what, I recently replaced the solenoid to no avail. Should I now replace the valve? Interestingly enough once I replaced the solenoid on the right side the left ballast wont fill.
    2008 LSV

  2. #2
    Join Date
    Sep 2012
    Location
    Tucson, Az
    Posts
    37

    Default Ballast continues to fill

    I had a similar problem, but for me it was the front ballast. I changed the sprinkler valve and my problem went a way. I could finally the the front when I wanted to. When I pulled the old sprinkler valve out and I blow thru the value it was like there was no valve.
    Good luck
    David
    2007 Moomba LSV

  3. #3
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,054

    Default

    Run a search on here on "sprinkler" or "sprinkler valve" and see what turns up. They are a little temperamental but you can deal with them. Run a search on "Irritrol" if you want a valve replacement that's a little better and a little higher flow. Good luck!
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



  4. #4
    Join Date
    Jan 2009
    Location
    Salem, OR
    Posts
    110

    Default

    That's exactly what I thought, I will change it out tomorrow. Thanks
    2008 LSV

  5. #5
    Join Date
    Jan 2009
    Location
    Salem, OR
    Posts
    110

    Default

    I just replaced the valve, its as good as new.
    2008 LSV

  6. #6
    Join Date
    Oct 2009
    Location
    Lockport, IL/Cloverdale, MI
    Posts
    141

    Default

    I have the same problem but with the left ballast, fills no matter what. Have to constantly have pump running to empty it while the center and right fill....which takes forever. Doesn't the solenoid open/shut the valve? It would seem if the solenoid was "off" then the valve should not be open. I guess I need to try replacing the valve too.
    2008 Outback V

  7. #7
    Join Date
    Jan 2009
    Location
    Salem, OR
    Posts
    110

    Default

    Yep, replace the valve. It's cheap and easy.
    2008 LSV

  8. #8
    Join Date
    May 2013
    Posts
    130

    Default

    I was looking at switching to the higher flow valves but the cost to benefit didn't seem to add up. Are you seeing noticeable faster fill times with them?

  9. #9
    Join Date
    Jan 2009
    Location
    Salem, OR
    Posts
    110

    Default

    I'm still using the stock valves but when I do an upgrade I will definitely go with individual pumps.
    2008 LSV

  10. #10
    Join Date
    Nov 2010
    Location
    Katy, TX
    Posts
    4,094

    Default Ballast continues to fill

    Quote Originally Posted by Cauley View Post
    Ok, sorry I have a 2008 LSV with a center and rear ballasts. I have moved the switches on the valves to open and closed and it doesn't change - water continues to fill when at speed or when I fill rear bags. So I assume I can take off the 8 or so screws on the front of the valve but then what-how do I clean it or will it be self explanatory once I open it? Then based on comment can i just get a new value at Home Depot and plug and play? Thanks again. This is a new boat for me (1 month) and love it but I have a lot to learn.
    I tried to clean them before and when I put it back together none of them worked. At like $15 each I would just go to Home Depot and buy a new one. That's what I did for all three


    Sent from my iPhone
    David

    2008 Mobius LSV, Gravity III , Wake Plate, Z5, Exile SX65c's, Exile XM9s, Exile XI12D, Exile Harpoon, Exile SM600.1 , Exile Xi800.4.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •