Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2013
    Posts
    1

    Default Sacs don't match %filled on cruise display

    Just bought slightly used 2012 MOJO 2.5. Owners manual wasn't clear if I need to be in neutral or at a certain rpm to fill tanks. I have filled and emptied doing both neutral and 1200rpm. I have had various issues w/ them not filling and not emptying. The % on digital display also doesn't match the amt. in the tanks. Any wisdom would be appreciated!





    2012 mojo 2.5

  2. #2
    Join Date
    Jul 2012
    Location
    Anderson SC, On Hartwell BABY!!!!!
    Posts
    42

    Default

    The dash just goes on the amount of time the pumps have been running. If the pump cavitates or whatever, the timer will continue to count, up or down, and nothing is happening. I usually fill mine mostly sitting still without the engine running, though it makes the pumps run a little slower so the amounts are not exactly right. If you are moving at above idle speed the pumps usually don't move water either. I can empty mine when idling back to the dock and usually do.

    It's not a flow activated system, that would be nice but would add a layer of complexity and expense. I just use the timers as a guide and look at the bags to make sure what is happening. It's not perfect but isn't a real problem either. Not unusual for me to run the pumps a few cycles after the bags are empty until I hear them stop pumping to be sure the bags are empty.
    Kevin
    2012 Launch 242

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •