Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2011
    Location
    Charlotte, nc
    Posts
    112

    Default operating temp fluctuations

    So my operating temp is usually 160 and doesn't move much at all. Lately when surfing as soon as I come off the throttle to idle, operating temp spikes about 15 degrees and I smell the engine running hot. After a little temperature returns to normal. All throughout surfing engine temp is stable. Week long vacation to lake Norman next week and I don't want this to be a precursor to something more serious. Any help is greatly appreciated. Surfing with 750 in locker, 400 up front, 3 people in boat with driver, stock prop.
    2014 SC350
    2012 LSV - sold

  2. #2
    Join Date
    Jul 2002
    Location
    London Ontario Canada
    Posts
    1,853

    Default

    Is your impeller old, do you have water strainer. When you idle down after running hot the impeller flow pressure is reduced and I believe it is normal for a temperature rise. Mine is usually 6-9 degrees. If I rev the engine in neutral the temp will drop back immediately otherwise it takes about 30 secs for it to drop back down. An increase in this spike may indicate a wearing impeller. Make sure you have a spare. A water strainer will increase the life of your impeller
    09 21v LAUNCH

    run your engine after you change your oil
    68 th Member. WS420,HSE Revolution, OJ 466, Acme1157,1100 sacs,Kicker HLCD's n IX500.4, Supra Coolies
    Doug

  3. #3
    Join Date
    Aug 2011
    Location
    Charlotte, nc
    Posts
    112

    Default

    So i replaced the impeller, checked the water strainer, tightened up any and all hoses i could find. This is still happening and I'm still seeing a lot of steam(it has a very mild odor) coming from the exhaust when were running a significant amount of weight(2250lbs surf and wake). Any other ideas
    2014 SC350
    2012 LSV - sold

  4. #4
    Join Date
    Feb 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    686

    Default

    Check not just the water strainer, but the entire intake system. It might be clogged somewhere.
    2005 XLV, upgraded ballast, Comptech swivel wakeboard and hydrofoil racks, Monster cargo bimini

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •