Results 1 to 10 of 10

Thread: Heater Help

  1. #1
    Join Date
    Sep 2013
    Location
    North Carolina
    Posts
    17

    Default Heater Help

    Hey new to this forum have loved all the info so far! Now I need help had the boat out today turned on the heater it runs fine on low but after about a min. on high it trips the breaker under the heater switch tried doing a search but no luck.
    04 Mobius LSV
    340 HP

  2. #2
    Join Date
    Dec 2004
    Location
    Cinci-Dayton
    Posts
    981

    Default

    Is the boat new to you or has it worked in the past?
    Naked red and white 2005 Moomba LSV
    Teaching my kids to Ride, Shoot Strait and Tell the Truth

  3. #3
    Join Date
    Sep 2013
    Location
    North Carolina
    Posts
    17

    Default

    I've had it a couple of months talked to the folks I got it from and they said it had always worked for them.
    04 Mobius LSV
    340 HP

  4. #4
    Join Date
    May 2010
    Location
    Salt Lake City, Utah
    Posts
    194

    Default

    I wonder if you have a loose connection somewhere. I would start with the obvious stuff like checking all electrical connection and make sure you have the right fuse in.
    scott
    2007 Mobius LSV with a lot of great mods

  5. #5
    Join Date
    Sep 2013
    Location
    North Carolina
    Posts
    17

    Default

    Thanks...looks like everything is connected I made sure and tried it again still the same runs on high about a min the trips the breaker.
    04 Mobius LSV
    340 HP

  6. #6
    Join Date
    Aug 2011
    Posts
    747

    Default Re: Heater Help

    Call heater craft... probably need a new motor..

    Sent from my Nexus 4 using Tapatalk 2
    2002 Moomba Mobius LSV

  7. #7
    Join Date
    Sep 2013
    Location
    North Carolina
    Posts
    17

    Default

    OK Thanks I'll try them tomorrow guess they have a web site?
    04 Mobius LSV
    340 HP

  8. #8
    Join Date
    Dec 2006
    Location
    Tigard, Oregon
    Posts
    3,016

    Default

    Al

    2006 Mobius LSV

  9. #9
    Join Date
    Sep 2013
    Location
    North Carolina
    Posts
    17

    Default

    Thanks Al.
    04 Mobius LSV
    340 HP

  10. #10
    Join Date
    Sep 2013
    Location
    North Carolina
    Posts
    17

    Default

    Talked to James today at Heater Crafter it was a bad breaker below the switch.Thanks for all the help and steering me in the right direction.
    04 Mobius LSV
    340 HP

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •