Results 1 to 10 of 15

Hybrid View

  1. #1
    Join Date
    Mar 2010
    Location
    Irondequoit Bay, NY
    Posts
    1,298

    Default distribution blocks

    looking for new blocks. i was sold 2 blocks made by stinger like this + from a local shop and i hate them, it got me through the summer, fixing it almost every time we went out since the 0 ga kept falling out. i wanna get new blocks that are better and come in and out straight ( digital is a plus ). looking for 0 in and 3 8ga? (i think ) out. ill have to look again.
    2004 Outback Blue/white w/5.7 indmar 350, Direct Drive
    Rockford fasgate cabins
    Rockford fasgate 500w amp (cabin) and a kenwood HU (kmr700u)
    Exile XM7's
    Exile Harpoon
    Exile ZLD
    Polk 10in sub (2)
    Polk P330 amp (subs)

  2. #2
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,137

    Default

    This: Tsunami TPFDB-4PG.

    takes care of both pos/neg with one block. 0gauge in and 4/8 out.
    '06 Supra Launch 20SSV-gone but never forgotten

  3. #3

    Default

    Also, heavy-gauge multi-strand wire is resilient, especially when you add in the shock and vibration of a towboat, so avoid very tight radiuses leading into your terminations.

  4. #4
    Join Date
    Oct 2012
    Location
    Greenville, SC
    Posts
    105

    Default

    I'm currently working on an install and used a single T-spec distribution block and a T-spec inline fuse for my dual amp setup. It looked like the brand that would come in the exile kit, so figured it must be pretty good stuff.

    The block I used handles the positive and negative feeds and 0 gauge in 4 gauge out. I haven't even turned the system on yet, but seems sturdy enough.

    http://www.amazon.com/T-Spec-V12DB-1...ribution+block

  5. #5
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    737

    Default

    Is your 0 ga undersized?

  6. #6
    Join Date
    Mar 2010
    Location
    Irondequoit Bay, NY
    Posts
    1,298

    Default

    what does that mean?. when i set up the blocks i kinda did a crappy job of where i mounted the posi block. so it would be at a 90* at the bottom of the board. so it would come out with the vibration and pounding of the water..i just got those stingers because i was kinda in a rush and just kept them for the summer. i might re wire the board this spring with new blocks and make it all look more clean
    Last edited by motosno963; 03-05-2014 at 01:20 PM.
    2004 Outback Blue/white w/5.7 indmar 350, Direct Drive
    Rockford fasgate cabins
    Rockford fasgate 500w amp (cabin) and a kenwood HU (kmr700u)
    Exile XM7's
    Exile Harpoon
    Exile ZLD
    Polk 10in sub (2)
    Polk P330 amp (subs)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •