Results 1 to 8 of 8
  1. #1
    Join Date
    Mar 2014
    Posts
    10

    Default Having Electrical Issues with 2008 Outback V

    Hey, all last last summer I was having issues with functions on my outback v. Some of the things that happened were,
    - When I would press the heater button to the hi or low position, all other button functions (NAV/ANC, Court., Bilge, Stereo,Acc) would turn on. And when I turned the heater button to the off position, all those functions would turn back off.

    -Perfect pass would cut out often. Noticeably more when riding on choppy days.

    - I put a CB radio (Cobra 19 DX IV) into the boat with the power source being the 12V lighter outlet. When ever talking on this radio while sound system was on, the sound system would get extremely muffled, and would hiss like crazy.

    - I have two amps (factory installed, both Kicker), a ZX250.2 running the tower speakers, and a ZX700.5 running the rest (I believe it is 6 speakers and a sub). They always have a hiss to them, and near the end of the summer the tower amp would cut out. It would just power down and then reboot.

    I thought it might be a power shortage or fuse issue, but I am pretty new to boat mechanics and am by no mean an electrician.

    Does anyone have any idea as to what might cause these issues?? And how I might fix them?
    If you do I would greatly appreciate it.

  2. #2
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    837

    Default

    Does your boat a dual battery setup? For the most part, what you describe sounds like a low voltage issue, which could lie in either the B+ or B- circuits. Give then that are experiencing issues with the helm electronics and the audio amps, which should be connected directly to the battery/switch and not fed off the helm, I would look close at the battery connections and the main cables.

    A visual inspection and well as checking that there is a good tight connection is first. Also knowing the condition of the battery(s) will be important, but just know that a low battery level could be a cause of the issue or the effect of a poor cable. But knowing the batteries level helps to get on the right path.

  3. #3
    Join Date
    Mar 2003
    Location
    s.e. washington state
    Posts
    2,113

    Default

    You are switching the ground common to all those circuits and not the positive. Check the wiring on the switch. Get your meter and start tracing with the suspected culprit is the switch. It could be a feed through the motor to the switch.
    1998 Mobius
    310 HP PCM

  4. #4
    Join Date
    Mar 2014
    Posts
    10

    Default

    Right now it is all run on one battery. Would a power shortage turn on all the other buttons functions like that?

  5. #5
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    837

    Default

    DC requires both the B+ and B- in order to complete the circuit. issue on either will cause problems. A poor ground or ground cable issue can cause other components to seek out a ground path through shared circuits. Knowing you are starting with good voltage and working out to the devices looking for a drop.

  6. #6
    Join Date
    Mar 2014
    Posts
    10

    Default

    Ok I will check for the voltage drop.
    What exactly do you mean by B+ and B-?
    I do not know a bunch about it.

  7. #7
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    837

    Default

    Sorry, battery positive and battery negative. DC voltage is the difference in potential between the two.

  8. #8
    Join Date
    Mar 2014
    Posts
    10

    Default

    Ok thank you. I will go through and check

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •