Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2008
    Location
    Hilliard, Ohio
    Posts
    479

    Default Oil coming out exhaust????

    Finally have time to get our new Mondo ready for some time on the water. After loading her up last night with boards and safety equipment I had moved hera second time in the driveway. At first I thought the kids sprayed cleaner on the driveway. But on closer inspection it was oil. The wake plate was covered along with the prop guard on the trailer with oil. Will pull cover in am and check the flyids can't call the dealer till Monday. Any ideas???

  2. #2
    Join Date
    Oct 2012
    Location
    Greenville, SC
    Posts
    105

    Default Oil coming out exhaust????

    Could you tell what color or type of oil it was? Hydraulic from the wake plate or maybe overfill from the v-drive? I had some in the belly of my 21v this spring, but all fluid levels were spot on and nothing was dripping from anywhere. I even put paper towels under the engine and v-drive for a week and not a drip. Thinking it was just from the dealer service.

  3. #3
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    6,044

    Default

    Wake plate are not an electric actuator.

    You shouldn't have any oil from the exhaust.

    Only thing I can think of is Winterization fluid from factory or dealer.

    Check the oil level while its on the trailer. Dealer can hook a fake a lake to it and run the engine to test it. Or take it to the lake and fire it up on the trailer see what happens.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  4. #4
    Join Date
    Aug 2009
    Location
    Oconomowoc, WI
    Posts
    108

    Default

    My guess the engine was preserved for storage and it may have been a little oil rich upon start-up and blew out the exhaust...

  5. #5
    Join Date
    Aug 2008
    Location
    Hilliard, Ohio
    Posts
    479

    Default

    Plug is in not from v drive. Knew the wake plate went electric not like the old ones.
    As far into the exhaust that I can reach its oily. I'll know more in the am once I take the cover off and check the fluids.

  6. #6
    Join Date
    Aug 2008
    Location
    Hilliard, Ohio
    Posts
    479

    Default

    Must have been left over from the double winterization. Boat ran great add I've 2 hours today.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •