Results 1 to 7 of 7
  1. #1

    Default 2012 Moomba Mojo Seems to have serious sluggish issues during acceleration.... help

    This just started a few weeks ago and I don't know exactly what to think of it. Here is the only way I can describe it...

    As I am throttling, it seems that the prop is not engaging with the water.... The RPM goes up and you can hear the engine rev up, but I am not accelerating like I should, I am WAY behind. It is like either the prop shaft is slipping, the prop is slipping, or the gears are slipping. It is the only way to describe the feeling.

    I looked at the prop and it needs to be reconditioned thanks to a few bumps and tweaks to it so I am wondering if that bumps are creating too many air bubbles and the prop is not connecting.

    I am taking her to the dealer tomorrow but before I do I was wondering if anyone here has had this happen to them and know what it is.

    Thanks!!!!

  2. #2
    Join Date
    Jul 2008
    Location
    Snellville, GA & Lake Sinclair
    Posts
    7,018

    Default

    maybe from the "bumps and tweaks" you've knocked the key loose and your spinning the prop on the shaft?
    Drew
    New ride: 2012 Mojo
    Old ride: 2008 OBV

  3. #3
    Join Date
    Aug 2011
    Posts
    1,054

    Default

    The prop is causing cavatation(air bubbles) have it repaired..
    2002 Moomba Mobius LSV - Sold
    2006 Moomba Mobius LSV

  4. #4

    Default

    Quote Originally Posted by wolfeman131 View Post
    maybe from the "bumps and tweaks" you've knocked the key loose and your spinning the prop on the shaft?
    That's what Cindy said Drew.. Hope it's not the tranny...

  5. #5
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,254

    Default

    Ouch. I would definitely check my fluid levels in my v-drive and tranny, check coupler bolts to the shaft, inspect the keyway. Shoot, just take it in. (I'd also throw my back up prop on and go for a ride though.)
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



  6. #6
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    6,020

    Default

    That just doesn't sound right. I'd check transmission fluid, and stop running the boat. until you find something wrong. Other wise you might do some real damage.

    Boat had a 2year drive train warranty. Take her in.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  7. #7
    Join Date
    Mar 2003
    Location
    s.e. washington state
    Posts
    2,095

    Default

    Put your spare prop on and see if that makes a difference. I think cavitation.
    1998 Mobius
    310 HP PCM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •