Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Static Radio

  1. #11
    Join Date
    Nov 2009
    Location
    Nebraska
    Posts
    424

    Default Static Radio

    http://www.meritline.com/m/showprodu...oductid=111239


    Sent from my iPhone using Tapatalk
    2010 Moomba LSV

  2. #12
    Join Date
    Nov 2008
    Posts
    265

    Default Static Radio

    Did you ever get an isolator? I just got the enabler and lots of interference. Wondering if the isolator degrades the sound quality at all.
    '13 Mobius LSV
    '05 Mobius LSV - Sold

  3. #13
    Join Date
    Nov 2009
    Location
    Nebraska
    Posts
    424

    Default Static Radio

    Going to get one soon, found when I turn up volume on boat, hard to notice


    Sent from my iPhone using Tapatalk
    2010 Moomba LSV

  4. #14
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    857

    Default

    Just a reminder: Any and all audio gear that uses a battery + and battery -, needs to share the same battery reference as the rest of the audio gear. If not, its an invitation for noise.

  5. #15
    Join Date
    Aug 2013
    Location
    DFW
    Posts
    384

    Default Static Radio

    MLA brings up a good point. I'll end up changing my 12v port at the helm to run off the same batts as the rest of the stereo.

    By chance did you try the setup on a home speaker to see if the noise was there? I first noticed noise on my G Grip, but once I changed out the DAC and better line in cable, the noise went away. The noise at first was a clicking sound, not the typical whine you hear.
    Matt
    2012 LSV
    4 XM9 Towers
    Javelin & XM30.2
    Xi 12DVC Sub
    2 6V Golf Cart Batteries
    FAE

  6. #16
    Join Date
    Nov 2008
    Posts
    265

    Default Static Radio

    I did try it at home, just on a Bluetooth speaker, but it sounded pretty good. I got an aftermarket DAC so I'm not using the one that came with it.

    I didn't think to check the 12v charger to see which battery it's using, but I will ASAP.
    '13 Mobius LSV
    '05 Mobius LSV - Sold

  7. #17
    Join Date
    Nov 2009
    Location
    Nebraska
    Posts
    424

    Default Static Radio

    Quote Originally Posted by Woody929 View Post
    MLA brings up a good point. I'll end up changing my 12v port at the helm to run off the same batts as the rest of the stereo.

    By chance did you try the setup on a home speaker to see if the noise was there? I first noticed noise on my G Grip, but once I changed out the DAC and better line in cable, the noise went away. The noise at first was a clicking sound, not the typical whine you hear.
    Yeah the clicking noise is what I hear



    Sent from my iPhone using Tapatalk
    2010 Moomba LSV

  8. #18
    Join Date
    Nov 2009
    Location
    Nebraska
    Posts
    424

    Default Static Radio

    Quote Originally Posted by csm View Post
    I did try it at home, just on a Bluetooth speaker, but it sounded pretty good. I got an aftermarket DAC so I'm not using the one that came with it.

    I didn't think to check the 12v charger to see which battery it's using, but I will ASAP.
    I also used the 12V and the USB to power. Didn't notice a difference


    Sent from my iPhone using Tapatalk
    2010 Moomba LSV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •