Page 4 of 4 FirstFirst ... 234
Results 31 to 37 of 37
  1. #31
    Join Date
    Jun 2013
    Location
    Huntsville, AL
    Posts
    45

    Default

    It was not posted online. My boat is affected by the recall and my dealer sent it to me. I have not looked on the Moomba site to see if is posted.

    Sent from my SGH-M919 using Tapatalk
    1991 Cobia Monte Carlo 188E (Sold)
    2014 Moomba Mojo

  2. #32
    Join Date
    Jul 2010
    Location
    Vicksburg, MI
    Posts
    460

    Default Re: Any ideas 2014 mondo trips ignition breaker

    Quote Originally Posted by samvq1 View Post
    It was not posted online. My boat is affected by the recall and my dealer sent it to me. I have not looked on the Moomba site to see if is posted.

    Sent from my SGH-M919 using Tapatalk
    I checked the Moomba, Skiers Choice, and Dealer Connect websites. Nothing was posted yet.
    Joe

    2014 LSV
    2010 Outback V - Sold

  3. #33
    Join Date
    Jun 2013
    Location
    Huntsville, AL
    Posts
    45

    Default

    I hope it was ok I posted it. I didn't think about it not being a public release document.

    Sent from my SGH-M919 using Tapatalk
    1991 Cobia Monte Carlo 188E (Sold)
    2014 Moomba Mojo

  4. #34
    Join Date
    Jul 2010
    Location
    Vicksburg, MI
    Posts
    460

    Default Re: Any ideas 2014 mondo trips ignition breaker

    Quote Originally Posted by samvq1 View Post
    I hope it was ok I posted it. I didn't think about it not being a public release document.

    Sent from my SGH-M919 using Tapatalk
    Perfectly OK. This forum is our best source of info. I already called my dealer. I was only curious about the article because I wanted to see the pictures.
    Joe

    2014 LSV
    2010 Outback V - Sold

  5. #35
    Join Date
    Sep 2013
    Location
    MN
    Posts
    97

    Default Any ideas 2014 mondo trips ignition breaker

    I think my boat just succumbed to this tonight after around 18 hours on the engine. Temp was at 120, no speed. I was wondering what was going on and then the engine just cut out. I should have been reading this before because we got towed back to the boat ramp but I could have got the engine started again. Will have to call dealer tomorrow. My wires don't appear melted at the white plastic pigtail but the wire leading to the actual black plastic hull mount appears melted and there is a brown fluid around that melted wire. No fun.


    Sent from my iPhone using Tapatalk
    Jesse

    2014 Mondo

  6. #36
    Join Date
    Dec 2012
    Location
    Trois-Rivieres, Quebec
    Posts
    127

    Default

    Just got my new Mondo...serial number is C414....
    Dealer is checking if my boat is in the list...
    Does anyone knows if I have to put the boat out of the water to fix this?? My Mondo is always in the water and I have no truck...shit!!
    And I guess I should unplug the pigtail in the meantime I get the new transducer??
    Sampp

    2014 Mondo

    Could be worst
    From nice Québec..

  7. #37
    Join Date
    Jul 2010
    Location
    Vicksburg, MI
    Posts
    460

    Default Re: Any ideas 2014 mondo trips ignition breaker

    Quote Originally Posted by Sampp1963 View Post
    Just got my new Mondo...serial number is C414....
    Dealer is checking if my boat is in the list...
    Does anyone knows if I have to put the boat out of the water to fix this?? My Mondo is always in the water and I have no truck...shit!!
    And I guess I should unplug the pigtail in the meantime I get the new transducer??
    Boat has to be out of the water either on a lift or trailer. Transducer has a short pigtail, and is only held in by a simple plastic ring. Simple to replace.
    Joe

    2014 LSV
    2010 Outback V - Sold

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •