Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Join Date
    Sep 2013
    Location
    MN
    Posts
    98

    Default New Mondo engine cut out while in transit

    Hey guys.

    So we were on the river tonight with our four kids. After pulling up to a beach to let the kids swim for awhile we started heading back to the boat ramp. While on our way, the engine just stopped. We have dual batteries and I tried both 1 and 2 but nothing happened. I made sure it was in neutral. I reset the circuit breaker by the battery switch but that didn't help. Just prior to the engine stopping, we were getting weird water temp readings and no mph readings at all. We started paddling in and were lucky enough to get a tow. I have the batteries plugged in now.

    Should the display work if I am charging the batteries? The radio, lights, other accessories work but the display won't turn on. Is there something else I should be looking for? Sorry this is my first boat so I am learning as I go and I appreciate all the help.


    Sent from my iPhone using Tapatalk
    Jesse

    2014 Mondo

  2. #2
    Join Date
    Sep 2013
    Location
    MN
    Posts
    98

    Default New Mondo engine cut out while in transit

    I looked under the dash at the ignition breaker and I had to reset that. Now everything is working again. Why would that have flipped while under way. We had the radio on and the kids had the heaters on. Nothing else should have been running. Little ticked at myself that I didn't calm down in the boat and think about looking at this. Oh well I am learning.


    Sent from my iPhone using Tapatalk
    Jesse

    2014 Mondo

  3. #3
    Join Date
    Aug 2010
    Location
    Nokomis, Saskatchewan
    Posts
    608

    Default

    Check the transducer which is down in the bilge area.. chances are the wires are melted. Its a noted issue search thru the threads as there is another thread regarding it

    Sent from my apple crushin android device
    2014 Mondo with da flow!!! Exile towers, stock everything else.... for now!

  4. #4
    Join Date
    Dec 2012
    Location
    Ennis, TX
    Posts
    170

    Default New Mondo engine cut out while in transit

    Why hasn't SC issued a recall on the boats instead of letting folks break down on the water. This is obviously an ongoing issue on the new models.


    Sent from my iPhone using Tapatalk
    Shane
    2012 Mojo 2.5
    EXILED
    4 XM9 Tower
    6 SX65M Cabin
    1 XI 800.4
    1 XI 1500.1
    1MX 30.2
    EXILE ZLD
    Green LEDs

  5. #5
    Join Date
    Sep 2013
    Location
    MN
    Posts
    98

    Default New Mondo engine cut out while in transit

    Quote Originally Posted by smorris7 View Post
    Why hasn't SC issued a recall on the boats instead of letting folks break down on the water. This is obviously an ongoing issue on the new models.


    Sent from my iPhone using Tapatalk
    Agreed. My series of events was identical to others on this forum and if it was not for this forum I would not have known that there was a service bulletin out for this issue. I should have been paying closer attention to the posts on this forum however it would have been nice to hear from the dealer as well. Mine goes in Monday to get fixed. Dealer didn't even have the new parts yet. They are on order.


    Sent from my iPhone using Tapatalk
    Jesse

    2014 Mondo

  6. #6
    Join Date
    Jul 2012
    Location
    Alexandria,Indiana
    Posts
    141

    Default

    Quote Originally Posted by smorris7 View Post
    Why hasn't SC issued a recall on the boats instead of letting folks break down on the water. This is obviously an ongoing issue on the new models.


    Sent from my iPhone using Tapatalk
    Would also like to know why they cant find the problem with all the wake plate issues,well over a year now and no one seems to have an answer
    2013 LSV Exiled
    2006 LSV (Sold)

    Jim

  7. #7
    Join Date
    Sep 2013
    Location
    Indiana
    Posts
    46

    Default New Mondo engine cut out while in transit

    ^ this


    2013 Moomba Mobius LSV
    2003 Ebbtide Campioné 210
    1969 Sea Ray SRV 170
    2013 Moomba Mobius LSV
    2003 Ebbtide Campione' 210
    1969 Sea Ray SRV 170

  8. #8
    Join Date
    Jun 2011
    Location
    Cincinnati, OH
    Posts
    13

    Default

    SC has issued a recall on this. happened to my 2014 Mojo and some others on the boards here. I saw the recall notice from my dealer after mine had already been replaced. If I remember right it affected boats manufactured from August thru March. Take it back to get fixed, because it is going to happen again in a worse spot if you dont
    2014 MOJO 2.5

  9. #9
    Join Date
    Mar 2014
    Location
    Alberta
    Posts
    23

    Default New Mondo engine cut out while in transit

    Does SC have a place that they post recalls publicly? Or are they just sent to the owner and/or dealer. Mines at the dealer right now and if it's effected by this recall, I'd rather get it done while it's there rather than drive the 3 hrs back a day or week or whatever after I pick it up.


    Sent from my iPhone using Tapatalk
    Lee

    2014 Mondo

  10. #10
    Join Date
    Sep 2013
    Location
    MN
    Posts
    98

    Default New Mondo engine cut out while in transit

    I never received notification personally and mine is going in on Monday to get fixed so I am assuming they do not send any notification to owner since I didn't hear anything from them prior to my issues.


    Sent from my iPhone using Tapatalk
    Jesse

    2014 Mondo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •