Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Nov 2013
    Posts
    174

    Default Audio help, again.

    07 LSV, cabin speakers are all 6.5" kenwoods (dont know model) powered by a kenwood excelon KAC-X542. They sound friggin awesome. The tower speakers are 4 polk 6.5" marine ready coax, and thos along with the kenwood excelon sub are on an Alpine PDX 5 amp.

    I just replaced the tower speakers a couple days ago, and ever since my PDX has been over heating. Leads me to think the speakers are too much for it? However, this is also the first really warm weather we've had too. First day we've used boat in air temps above 75° or so and all these days have been 90° plus.

    Now here is where it gets a bit strange. The PDX is 5 channels. My tower speakers are actually bridged onto two amp channels and then split again in the cans. Strange I know, but the factory speakers in these cans had a built in crossover in the can and it split again after the crossover for each speaker. When I installed new speakers, I didn't want to run more wire into the tower so I used the existing wire and just split once in the can.

    Could that be the cause of the amp over heating? My first step was to turn the gain down on the amp. That didn't really do anything. Next I turned down the sub at the HU, still gets hot and cuts out.

    Ideas.....? Go!
    2007 LSV

  2. #2
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    797

    Default

    What tower speakers are in there now and what was in there? Model specific as this makes a huge difference with the Polks.

  3. #3

    Default

    Quote Originally Posted by Beejwest View Post
    07 LSV, cabin speakers are all 6.5" kenwoods (dont know model) powered by a kenwood excelon KAC-X542. They sound friggin awesome. The tower speakers are 4 polk 6.5" marine ready coax, and thos along with the kenwood excelon sub are on an Alpine PDX 5 amp.

    I just replaced the tower speakers a couple days ago, and ever since my PDX has been over heating. Leads me to think the speakers are too much for it? However, this is also the first really warm weather we've had too. First day we've used boat in air temps above 75° or so and all these days have been 90° plus.

    Now here is where it gets a bit strange. The PDX is 5 channels. My tower speakers are actually bridged onto two amp channels and then split again in the cans. Strange I know, but the factory speakers in these cans had a built in crossover in the can and it split again after the crossover for each speaker. When I installed new speakers, I didn't want to run more wire into the tower so I used the existing wire and just split once in the can.

    Could that be the cause of the amp over heating? My first step was to turn the gain down on the amp. That didn't really do anything. Next I turned down the sub at the HU, still gets hot and cuts out.

    Ideas.....? Go!
    Yes, that is why the amplifier is overheating. Two 4-ohm speakers in parallel is 2-ohms and 2-ohms appears to be half the impedance when the amplifier is bridged. So it is like running 1-ohm stereo. Not many fullrange amplifiers are stable into that load. Nor is the PDX.

    The old passive crossover may have technically paralleled two speaker outputs. However, the stopband of each side of the crossover determined that the impedance rises significantly outside each speakers bandwidth. So you might have 4-ohms in parallel with 80-ohms at a particular frequency which is essentially still 4-ohms. The scenario you have now is COMPLETELY different.

    You have two choices.
    1) Leave the amplifier bridged and series the tower speakers on each channel. Net = 2 x 8-ohms bridged.
    2) Have eight conductors run up the tower and run four channels in stereo. Net = 4 X 4-ohms stereo.

    The final power and thermal stability will be identical in both examples 1) & 2). Option 1) would be easy with no additional wire.

  4. #4

    Default

    Also, the above options remain the same even if you have the Polk 2.7 ohm versus 4-ohm speakers.

  5. #5
    Join Date
    Nov 2013
    Posts
    174

    Default

    The new speakers are Polk Dxi 651 6.5" coaxial marine ready.
    So on option #2, i would just run more speaker wire right? Meaning that four each of 4 channels I'd have 8 conductors i.e. Normal speaker wire...
    2007 LSV

  6. #6
    Join Date
    Nov 2013
    Posts
    174

    Default

    Just checked the manual on the speakers, they are 4 ohm nominal so I'll run some extra wire tomorrow before surf-thirty and let ya know how it goes.

    Thanks. I didn't even think to check that. Obviously a newb in the audio department.
    2007 LSV

  7. #7
    Join Date
    Nov 2013
    Posts
    174

    Default

    Wait, would option 1 leave me at 4 ohms per speaker? 8/2=4? That would indeed be easier.
    2007 LSV

  8. #8
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,918

    Default

    Yes option 1 would be easier.
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  9. #9
    Join Date
    Oct 2010
    Location
    Lake Wylie NC Area
    Posts
    797

    Default

    Quote Originally Posted by Beejwest View Post
    Just checked the manual on the speakers, they are 4 ohm nominal so I'll run some extra wire tomorrow before surf-thirty and let ya know how it goes.

    Thanks. I didn't even think to check that. Obviously a newb in the audio department.
    Ok, with 2 pair of 4 ohm speakers, just wire them in series at the tower. This = 8 ohm bridged at the amp, so nothing there needs to be changed. As David notes, the speakers get the same power, but the series/bridge option means no more wire needs to be fished through the tower, just reconfigure the each pair at the pods.

    Also, any cross-over left over in the pod(s) from the previous set of speakers, should be left out of the new system. Do not connect to it.

  10. #10
    Join Date
    Nov 2013
    Posts
    174

    Default

    Awesome! I already cut out the crossover in the cans. Thank you guys! I'll let you know if it works or not, but it should be fine!
    2007 LSV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •