Results 1 to 4 of 4
  1. #1

    Default Mojo Gravity III Ballast Pumps mounting

    Good Morning- I recently removed the panel covering the pumps for the ballast system and I see they are mounted to a board. This board is not mounted to anything and is just being held in place by the fill/drain lines basically. I see the L brackets but do not see where this mounts as I cannot find any existing holes. Does anyone have a photo of this set up they can post for me. Thank you in advance

  2. #2
    Join Date
    Jul 2013
    Location
    Cedar Falls, IA
    Posts
    348

    Default Mojo Gravity III Ballast Pumps mounting

    I wondered about this as well when I saw mine so I contacted SC. This is intentional, the l brackets are not utilized. I've thought about putting some screws in it to help avoid harness and line rubs bit I think it's held pretty well by the lines and the cover panel.


    Sent from my iPhone using Tapatalk
    2013 Moomba Mojo 2.5
    Exile SXT9's, Xi12D, Javelin, 800.4, ZLD MKII

    2012 F150 Ecoboost

  3. #3
    Join Date
    Jul 2010
    Location
    Vicksburg, MI
    Posts
    449

    Default

    Same here on my 2014 LSV. Board was just sitting there with brackets not attached to anything. Didn't matter to me since I was moving the pumps anyway.
    Joe

    2014 LSV
    2010 Outback V - Sold

  4. #4
    Join Date
    Nov 2003
    Location
    Land O Lakes, Florida
    Posts
    5,814

    Default

    same on mine, no biggy really, its not going any where. mines sitting in the garage someplace--pumps moved.
    Hey, Its Moomba time

    13 Mobius LSV
    08 Mobius LSV-sold
    03 Mobius LSV-sold

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •