Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2011
    Location
    York Maine
    Posts
    19

    Default Radio works but the buttons do not

    Ok I have a 2011 obv and still have the factory mb quart radio and this year when I put my boat in the water the radio came on like normal but I then went to adjust the volume nothing happed. So it was playing music threw my aux cord but none of the buttons on my head unit work or the unit near the throttle work. Had anyone ever had this problem or know what the problem could be? Because it really sucks not being able to turn the music up for surfing.
    Mason
    if you cant fix it with a hammer then you have yourself and electrical problem

    always wondered if you catch a fish and release it, does it go back to its friends and tell them they got abducted by some aliens?

  2. #2
    Join Date
    Jul 2008
    Location
    Snellville, GA & Lake Sinclair
    Posts
    7,058

    Default

    Hate to be the bearer of bad news, but that MB Quart system sucked. Big time.

    Use the forum to search for which head unit to upgrade to.
    Drew
    New ride: 2012 Mojo
    Old ride: 2008 OBV

  3. #3
    Join Date
    Mar 2011
    Location
    York Maine
    Posts
    19

    Default

    I knew it was shitty just not that shitty haha it's only a couple years old but this is good because it was time to upgrade the head unit
    if you cant fix it with a hammer then you have yourself and electrical problem

    always wondered if you catch a fish and release it, does it go back to its friends and tell them they got abducted by some aliens?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •