Results 1 to 5 of 5

Hybrid View

  1. #1
    Join Date
    Jul 2002
    Location
    London Ontario Canada
    Posts
    1,851

    Default 2009 depth finder not working

    My depth finder only reads 997. Air n lake temps are good. Harness connectors seem fine. Any ideas on this before I deg deeper?
    09 21v LAUNCH

    run your engine after you change your oil
    68 th Member. WS420,HSE Revolution, OJ 466, Acme1157,1100 sacs,Kicker HLCD's n IX500.4, Supra Coolies
    Doug

  2. #2
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,297

    Default

    Try moving into some shallower water.
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



  3. #3
    Join Date
    Jun 2013
    Location
    Chandler, AZ
    Posts
    29

    Default 2009 depth finder not working

    My 06 lsv didn't come with a depth finder is this any easy install? What would you recommend and can it be installed without making a new hole?
    2006 LSV

  4. #4
    Join Date
    Jul 2002
    Location
    London Ontario Canada
    Posts
    1,851

    Default

    I knew there would be an easy solution.........thanks Pat.
    09 21v LAUNCH

    run your engine after you change your oil
    68 th Member. WS420,HSE Revolution, OJ 466, Acme1157,1100 sacs,Kicker HLCD's n IX500.4, Supra Coolies
    Doug

  5. #5
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,297

    Default

    LOL. Maybe ground wire. These can be finnicky.
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •