Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Join Date
    Jun 2007
    Location
    Rice Lake, Ontario
    Posts
    705

    Default 06 LSV bildge not working, not sure how to remove.

    Hey everyone. Been a while since i was on the forums.

    06 Möbius LSV

    Shaft was leaking bad when I came in yesterday and I didn't notice. It started to rain 4 hours later so I went to cover boat. There was about 4-6 inches of water in hull. Hit the bildge switch and nothing. No light. Hit the reset light and light came on but no bildge.

    Used the pump for my ballast bags to drain and tightened the shaft. Stopped the water for now.

    But the bildge won't come on.

    Is there another fuse beside the resetable one at switch?

    If I need to replace the bildge, how do I remove it? How do I disconnect it from the hull?
    2006 Moomba Mobius LSV
    Lake: Rice lake, Ontario
    Stereo: Kenwood KMR-550U
    Ballast: 750 Surfside locker, 400 Surfside mid boat, 400 Gravity I, 400 Bow
    Surfboards: Inland Surfer Red Woody, Triple X Composite X 58"

    If you're from the area and want to surf, send me a PM!

  2. #2
    Join Date
    Jun 2007
    Location
    Rice Lake, Ontario
    Posts
    705

    Default

    This appears direct replacement. Do I need to cut wires or will it just be plug and play? Can't see if there is a harness included.
    http://www.skidim.com/prodinfo.asp?number=6031726

    Any discounts available at skidim?
    Last edited by spyder; 07-20-2014 at 01:15 PM.
    2006 Moomba Mobius LSV
    Lake: Rice lake, Ontario
    Stereo: Kenwood KMR-550U
    Ballast: 750 Surfside locker, 400 Surfside mid boat, 400 Gravity I, 400 Bow
    Surfboards: Inland Surfer Red Woody, Triple X Composite X 58"

    If you're from the area and want to surf, send me a PM!

  3. #3
    Join Date
    Aug 2011
    Posts
    1,117

    Default Re: 06 LSV bildge not working, not sure how to remove.

    Does it turn on when you twist the knob on the side? Usually it gets stuck and doesn't turn on automatically. Open it and clean it, but it happens a lot with that pump style. I add a second pump to solve that..
    2002 Moomba Mobius LSV - Sold
    2006 Moomba Mobius LSV

  4. #4
    Join Date
    Jun 2007
    Location
    Rice Lake, Ontario
    Posts
    705

    Default

    Quote Originally Posted by parrothd View Post
    Does it turn on when you twist the knob on the side? Usually it gets stuck and doesn't turn on automatically. Open it and clean it, but it happens a lot with that pump style. I add a second pump to solve that..
    Turned the knob. Just soundes like a flap. Never turned on.
    2006 Moomba Mobius LSV
    Lake: Rice lake, Ontario
    Stereo: Kenwood KMR-550U
    Ballast: 750 Surfside locker, 400 Surfside mid boat, 400 Gravity I, 400 Bow
    Surfboards: Inland Surfer Red Woody, Triple X Composite X 58"

    If you're from the area and want to surf, send me a PM!

  5. #5
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,964

    Default

    Pop it out of its mount base using a flat head screw driver or strong fingers and see if impeller is jammed, carpet fibers sometimes get in there. Mine broke and I got it at Wally World, and swapped the pumps into the mounts and spliced the power cords.

    http://www.walmart.com/ip/Sahara-500...2-VDC/11071160
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  6. #6
    Join Date
    Jun 2007
    Location
    Rice Lake, Ontario
    Posts
    705

    Default

    Quote Originally Posted by jmvotto View Post
    Pop it out of its mount base using a flat head screw driver or strong fingers and see if impeller is jammed, carpet fibers sometimes get in there. Mine broke and I got it at Wally World, and swapped the pumps into the mounts and spliced the power cords.

    http://www.walmart.com/ip/Sahara-500...2-VDC/11071160

    does the walmart or skidim come with the harness like below?

    2006 Moomba Mobius LSV
    Lake: Rice lake, Ontario
    Stereo: Kenwood KMR-550U
    Ballast: 750 Surfside locker, 400 Surfside mid boat, 400 Gravity I, 400 Bow
    Surfboards: Inland Surfer Red Woody, Triple X Composite X 58"

    If you're from the area and want to surf, send me a PM!

  7. #7
    Join Date
    Jun 2007
    Location
    Rice Lake, Ontario
    Posts
    705

    Default

    I *may* have found one locally at Canadian Tire.. I will check to see if they have it in stock tomorrow.

    http://www.canadiantire.ca/en/pdp/au...-0793514p.html
    2006 Moomba Mobius LSV
    Lake: Rice lake, Ontario
    Stereo: Kenwood KMR-550U
    Ballast: 750 Surfside locker, 400 Surfside mid boat, 400 Gravity I, 400 Bow
    Surfboards: Inland Surfer Red Woody, Triple X Composite X 58"

    If you're from the area and want to surf, send me a PM!

  8. #8
    Join Date
    Jun 2007
    Location
    Rice Lake, Ontario
    Posts
    705

    Default

    Quote Originally Posted by spyder View Post
    I *may* have found one locally at Canadian Tire.. I will check to see if they have it in stock tomorrow.

    http://www.canadiantire.ca/en/pdp/au...-0793514p.html

    had it in stock, $62.. doesn't come with a wire hardness though so i'll have to splice... booo.
    2006 Moomba Mobius LSV
    Lake: Rice lake, Ontario
    Stereo: Kenwood KMR-550U
    Ballast: 750 Surfside locker, 400 Surfside mid boat, 400 Gravity I, 400 Bow
    Surfboards: Inland Surfer Red Woody, Triple X Composite X 58"

    If you're from the area and want to surf, send me a PM!

  9. #9
    Join Date
    May 2013
    Posts
    182

    Default

    Make sure the circuit board is plugged into the back of the switch. Mine comes undone when tubing really hard. I have to reach from the back along the gunnel to push it back on. The auto switch works but not manual when this happens

  10. #10
    Join Date
    Jun 2007
    Location
    Rice Lake, Ontario
    Posts
    705

    Default

    Quote Originally Posted by cornrickey View Post
    Make sure the circuit board is plugged into the back of the switch. Mine comes undone when tubing really hard. I have to reach from the back along the gunnel to push it back on. The auto switch works but not manual when this happens
    would that explain shorts? hrmm.. but manual and auto are not working on mine,.

    we were tubing and hit a few good bumps.
    2006 Moomba Mobius LSV
    Lake: Rice lake, Ontario
    Stereo: Kenwood KMR-550U
    Ballast: 750 Surfside locker, 400 Surfside mid boat, 400 Gravity I, 400 Bow
    Surfboards: Inland Surfer Red Woody, Triple X Composite X 58"

    If you're from the area and want to surf, send me a PM!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •