Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2014
    Posts
    10

    Default Having Trouble with Gravity 3 Ballast System

    Hello all, I am having lots of trouble with my 2008 moomba outback V, but this is the latest.
    First off, the system blew all recommended 5 amp fuses twice, so I switched to 10 amp fuses, and that seemed to work for awhile, but a few days ago the left one blew. I am very confused by this.
    Anyways I put in a 15 amp fuse and it will now pump again. I know this isn't ideal, but I really don't know what is going on with it. That's the first thing.
    Secondly, the empty pumps are having trouble completely. They will empty if I lift up the bags, but have trouble once they get low otherwise. I did not have this problem 2 weeks ago, so I am confused.
    Third, and most annoying, both back tanks fill when I turn on any of the switches, and always the left faster than the right..
    Very annoyed, I check all the valves, and the actuators (black nob things that have metal cylinder that get sucked in when the appropriate switch is turned on) seem to open just fine.

    If anyone can help me out I would be very appreciative!
    Thanks

  2. #2
    Join Date
    Jan 2008
    Location
    Keuka Lake, NY
    Posts
    5,815

    Default

    Check for kinks in the fill lines, clean out the valves, and position the drain pumps so they stay primed or check for air leaks. I added vents to my 2007 that helped the drain flow through the same through hull.
    A Day at the Lake...Priceless
    A Day in Powder...Endless


    Joe V
    2012 Möbius XLV~ Loaded & Exiled
    2007 Outback V ~ sold

  3. #3
    Join Date
    Mar 2014
    Posts
    10

    Default

    How did you add vents? Any special product?

  4. #4
    Join Date
    May 2013
    Posts
    173

    Default

    Mine has 7.5 in which I'm assuming is stock. If yours is 5 you have tripled the amp capable for the system design. I'd you blowing fuses you have a excessive current draw which is probably from a bad pump. No ballast system is not worth burning your boat down. Fix the problem, don't increase the fuse size.

  5. #5
    Join Date
    Mar 2012
    Location
    South Carolina
    Posts
    778

    Default Having Trouble with Gravity 3 Ballast System

    Quote Originally Posted by pieperk View Post
    How did you add vents? Any special product?
    Vent lines from wakemakers can be installed, I did this on my 21V this summer and it indeed helps to drain those rear sacs.
    2008 Supra 21V
    2,600 lbs., Gravity III
    Z5 Cargo Rack
    Stereo: Pair of Wetsounds Pro 80's, Rockford Fosgate P500-2, Kicker ZX200.4, Exile ZLD, stock Kicker in-cabins, stock Kenwood HU
    Tow rig: 2008 Slate Tundra, Bilstein 5100's (F&R), 295/65/18 wrapped in Duratracs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •