Results 1 to 7 of 7
  1. #1
    Join Date
    Jan 2014
    Location
    Kelowna, BC Canada
    Posts
    121

    Default Throttle/Perfect Pass issue??

    Yesterday was out surfing and had PP set at 9.6. Everything is fine and then all of the sudden BAM the boat stops instantly. It was like someone just completely cut all power. I am surfing behind and realize what has happened and have to bail hard right to avoid hitting the back of the boat. Checked with the driver and throttle was still buried and he insists he didnt touch a thing. Still power to the boat. Just had to turn the key and it started right back up.

    Very same thing happened to me the day before when I was on the back ... actually grazed the back corner of the boat.

    Also happened again once before a few weeks ago when I was driving and my wife was on the back. It has only ever happened when surfing ...

    Any idea what this could be??? It freaks you out a little knowing that at anytime the boat could stop and you have to be ready to bail. I'm just terrified that it will happen when we have someone up there who is just starting out and they smack their head off the back of the boat.
    2014 Black/White Mojo
    345HP Surf Motor
    1235 Prop
    Moomba Flow
    900# Sumo Rears
    650# IBS

  2. #2
    Join Date
    May 2014
    Location
    Clermont, Fl
    Posts
    302

    Default

    funny you mention this - same thing happened to me, but my engine didn't shut off - the boat just lost all forward speed.

    My wife and brother in law (who was surfing at the time and made a grand entrance into the boat) blamed it on me.

    I have the stargazer - wonder if it was some kind of satellite hick-up?
    Ed Geary
    2009 Moomba Outback V
    Clermont, Fl

  3. #3
    Join Date
    Jan 2008
    Location
    Tallahassee, FL
    Posts
    11,242

    Default

    I had the same thing the other day. Somehow I bumped the lanyard switch and had a momentary interruption.
    My Mom said I'm not allowed to get wet!
    2008 LSV
    2000 Outback LS (sold)
    Exile Tunes
    PWI
    LLTR!!!!!!!!



  4. #4
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    6,020

    Default

    Each time we had that happen it was bumping the lanyard.

    It barley takes any contact and it will cut the power off instantly.

    I found myself doing it once because sometimes I kick my feet back under the seat.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  5. #5
    Join Date
    Jan 2014
    Location
    Kelowna, BC Canada
    Posts
    121

    Default

    Hmmmmm Ok I will test it out when I am in the water next. Maybe it was the lanyard like you said ...
    2014 Black/White Mojo
    345HP Surf Motor
    1235 Prop
    Moomba Flow
    900# Sumo Rears
    650# IBS

  6. #6

    Default Throttle/Perfect Pass issue??

    The linkage could be getting snagged on the engine cover or something else. I believe that will shut off everything.


    Sent from my iPhone using Tapatalk

  7. #7
    Join Date
    Feb 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    686

    Default

    Also check the electrical connections. On the model on my boat, they are not shielded against water, so corrosion or am intermittent short circuit could be an issue.
    2005 XLV, upgraded ballast, Comptech swivel wakeboard and hydrofoil racks, Monster cargo bimini

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •