Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2002
    Location
    Oregon
    Posts
    33

    Default Speedo not working

    Brian, About 3 weeks ago my speedo quit working. I ordered a new speedo from Moomba and installed this weekend and I still do not have any needle movement. Any ideas? I have power to the unit as the light works and everything else checks out. Maybe the paddle wheel sending unit?

  2. #2
    Join Date
    Aug 2002
    Location
    Maryville, Tn.
    Posts
    382

    Default Damn Speedos

    Dan, it is more than likely to be the transom mounted paddle wheel. To verify this, it can be checked on the backside of the speedo with a volt meter. For reference, the bare wire is ground, the blue wire is pos. and the blk. war(Tn. slang for wire) is the signal war. With the key in the on pos. not crank, and having someone spin the paddle wheel by finger, with the neg. lead of the meter on gnd., and the pos. on the blk. war, you should get a reading of 2-6volts. If not, more than likely a paddle wheel replacement. If this is needed, I suggest updating to the thru-hull paddle wheel. It is more accurate at speeds(when turning) and is adaptable to Perfect Pass, for late installation. Hope it helps, keep me posted. Brian Raymond

Similar Threads

  1. Speedo question...
    By bobwells in forum Service & Repair
    Replies: 10
    Last Post: 07-18-2007, 01:27 PM
  2. Calibrating Speedo
    By e420x in forum General Chat
    Replies: 5
    Last Post: 10-08-2005, 07:49 PM
  3. speedo
    By fastway in forum Service & Repair
    Replies: 1
    Last Post: 01-13-2004, 11:19 PM
  4. Speedo is off
    By ProXman in forum Service & Repair
    Replies: 0
    Last Post: 11-10-2003, 01:00 PM
  5. speedo not working - Airguide
    By mtvfiremedic in forum General Chat
    Replies: 1
    Last Post: 07-12-2003, 01:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •