Results 1 to 10 of 10
  1. #1
    Join Date
    Oct 2010
    Location
    Pittsboro, NC
    Posts
    327

    Default Hesitation when accelerating and loss of power

    Around 100 hrs I started to get a hesitation when pulling a skier up or under hard acceleration. I did the normal, changed the fuel filter checked for water in the gas. No water in the gas and changing the fuel filter seemed to fix the problem. At 120 hrs same thing started again, but this time it would back fire a little during some hard pulls and basically lose power for a split second then go on. It doesn't matter if the engine is cold or hot or how long the engine has been running. Changed the fuel filter again and checked for water in gas once again, no water in gas. Each time I have changed the fuel filter I have noticed there is very little fuel in fuel filter and line.

    Continued with the same problem next time out, but worst this time. Surfed for about 2 hrs with about 1900 lbs if ballast and when we stopped and dumped the ballast and went to restart engine, the engine was running rough and would not rev at all, so we limped back to the dock and left (good thing it was the last run of the day). Also tried the cold water on fuel pump no help.

    Next day I hooked the fake lake up and a fuel pressure gauge and started engine. Engine was running rough, the fuel pressure was jumping from 30-50 psi and then leveled out @ 62 psi and engine started running fine. The last few times out same thing with hesitation but I have not had the rough running problems again. I now have 145 hrs on the engine, which 120 hrs was this year alone. 1st 100 hrs no problems at all. I keep all the maintenance up myself and do it by the book.

    I know from mechanical experience that most electric fuel pumps are made to push fuel and not pull fuel, but there is no supply fuel pump @ the tank only the pump @ the engine. They do offer an electric supply pump which is supposed to help with this problem ($300.00). I have also read on one of the many searches that a fuel check valve in the fuel line was faulty and that fixed their simular fuel problem. And I also know that the new Moomba's fuel pumps are in the tank like most other fuel injected boat engines.

    Has anyone had 1st hand experience with fixing the fuel supply problems that so many of us Moomba owners encounter.

    Maybe someone from Indmar could chime in or anyone help would be appreciated.
    Patrick
    '08 Mobius LS. 4 Blade OJ 13x13 Prop.
    Kenwood KMR440U & RC107MR, T600-2 Rockford Fosgate powering 2 Liquid Acoustics 8" HLCD, Kicker SKM10 subwoofer
    5 light- light bar.

    Live life today!

  2. #2
    Join Date
    Oct 2010
    Location
    Pittsboro, NC
    Posts
    327

    Default

    Went out for the last ride of the year today and surfed for about an hour, but same problem continued. I was hoping that the cooler temps (62 degree water & 70 degree air) would help but it did not. I guess I will go ahead and winterize the boat and start to tear the fuel system apart and hope I find something.
    Patrick
    '08 Mobius LS. 4 Blade OJ 13x13 Prop.
    Kenwood KMR440U & RC107MR, T600-2 Rockford Fosgate powering 2 Liquid Acoustics 8" HLCD, Kicker SKM10 subwoofer
    5 light- light bar.

    Live life today!

  3. #3
    Join Date
    Jan 2009
    Location
    Bennett NC
    Posts
    95

    Default

    Ours had a similar problem on our first trip out this spring. I changed fuel filter and added fresh 89 octane gas and it fixed it, no problems since. I also add marine stabil every time I add gas.
    2007 Moomba Outback V
    2007 F-250 PSD CC

    Sky Ski Le-38
    XXX front wing
    UFO rear wing
    Evo tower

  4. #4
    Join Date
    Sep 2010
    Location
    Mckinney, TX
    Posts
    279

    Default

    Change the filter again and add Berrymans in the gas tank once a month..with some of the cheap gas we buy sometimes (unknowingly) If your having a demand problem 90% of the time Its a filter or the fuel pump and pumps dont go out that much. I keep a glass filter coming from the tank and another one between the fuel pump and the engine so I can see what is coming out of the tank and how clean it is going into the eng. But Its not uncommon for me to clean them twice a year. Jet
    89' Comp Resto:
    http://supraboats.com/bbs/showthread.php?t=8193

    Riding and Mod pic's:
    http://www.supraboats.com/bbs/album.php?albumid=86

    89' Supra/Custom Tower & Interior/Swivel Racks
    4 Blade-14X14/1600 lbs Ballast
    Roswell Bar/Led's/Krypt 6.5 HLCD's/Krypt 4200 Eq
    JL-PPI Amps 1750 Watts/Kicker Interiors/L7 Kicker Sub

  5. #5
    Join Date
    Mar 2008
    Location
    Calgary, AB, Canada
    Posts
    71

    Default

    I was having similar problems. It was the fuel filter. After some investigation I was amazed how much CRAP I blew out of the old filter. I buy good gas (so I thought) and fill from portable clean cans off the dock. I decided to add a 'spin on' fuel filter / water separator instead of the 1/2" x 1/2" in-line filter. It has run like a dream ever since. The big spin on filter is pretty inexpensive and the housing was pretty cheap too. I bought mine at auto parts store buy Skidim.com has them too (15% everything off if you buy by the end of today using promo code ALLNEW). This is identical to the one I bought. http://www.skidim.com/prodinfo.asp?number=SIE18-7852-1

    At the very least it provides better fuel filtration and it is simple to just spin on a new fuel filter when it needs replacing. You could have had some dirt or solids get into your tank and they are just keep clogging up your filter? Just a guess though. That 1/2" filter clogs off pretty easy.
    2007 Mobius LS

  6. #6
    Join Date
    Oct 2010
    Location
    Pittsboro, NC
    Posts
    327

    Default

    OK 1st chance to look at the boat since winterizing in late November. After evaluating the fuel delivery system in my boat I have come to the conclusion that the fuel supply system is a pi$$ poor designed from the get go.
    1st) The use of a non-pressurized system from the tank to the engine is a baaad design. Electric fuel pumps are designed to push fuel not pull fuel.

    2nd) Having to suck fuel out from top of the tank, then almost another 8" in height to the fuel filter, before going down hill to the electric fuel pump.

    3rd) 1/2 fuel supply lines that are clamped. I have never owned a boat that fuel lines were clamped.

    4th) 1/2" x 3/8" npt anti-siphon valve on top of the tank that has a 1/4" hole for fuel to flow through were the check valve is at. "I suspect this check valve may be the majority of my fuel issues" Evertime I have removed the fuel line from the inlet of the fuel filter there has been no fuel in the fuel line from the tank to the fuel filter.

    So I started by removing the fuel line from the tank to the fuel filter, there was only a few drops of fuel in the line. Checked the fuel filter which had about 10 hrs on it and it blows and flows freely.

    Next I removed the anti-siphon valve from the top of fuel pick up and did some basic checks on it and appears as if it works (but I still suspect this is part of my problem and will replace it) I am not exactly sure what the opening pressure of the valve is so my checks are not 100% accurate.

    Next I removed the pick up tube from the tank to inspect. Every things seems to be intact and the screen on the tube is clear of debris.

    Next I removed the fuel pump from the back side of the engine and pulled the small screen from the inlet of the fuel pump and it was also clear of debris, cleaned while I had it apart and reinstalled. I also checked the 1/2" fuel line from the filter to the pressure pump and there was no obstructions.

    I have completely disassembled the fuel system from the tank to the pressure side of the fuel pump and have found no obstructions. I am still leaning towards the anti-siphon valve as the problem or perhaps the fuel pump has an intermitent loss of pressure. But I did have 62 psi of pressure when I was checking the fuel pressure and in my experience most vane style electric pumps don't loose pressure intermittantly, they usually stop working or have very low pressure when they go bad.

    I still need to siphon the fuel tank and check the fuel for water in the tank. And if there is none I am almost at a loss of what to do next.
    Has anyone retrofitted this fuel system with fully pressurized system. And if so lead me in the right direction to get started. That is what this boat should have come with from the get go for the amount of performance the engine is putting out.
    Patrick
    '08 Mobius LS. 4 Blade OJ 13x13 Prop.
    Kenwood KMR440U & RC107MR, T600-2 Rockford Fosgate powering 2 Liquid Acoustics 8" HLCD, Kicker SKM10 subwoofer
    5 light- light bar.

    Live life today!

  7. #7
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    6,008

    Default

    I like where you headed with this, several people have had these issues and no real consistant resolve has been created. I havnt had any of the fuel problems yet. As the boat comes into its 4th season i expect something to start going problomatic but then again i hope not LOL. I try to be meticulous about my maintenance to the boat like i am with my Diesel.

    Im leaning to the check valve sticking, or possible bad connections at the fuel pump. Connections are the most comming thing i have herd going wrong.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

  8. #8
    Join Date
    Oct 2010
    Location
    Pittsboro, NC
    Posts
    327

    Default 1st Attempt to fix hesitation issue

    This is were I stand. I went through the complete fuel system (as stated a couple of post up) trying to find an actual issue that would have caused the hesitation. I really didn't find anything that could of caused the issue, other than a lot of weak points up to the pressure pump that is attached to the engine.

    1st: The hard plastic pick up tube is only slid over the fitting with no clamps or sealer. I sealed the pick up tube with fuel approved sealer. There isn't enough room to clamp the pick up tube and slide it back through the hole in the fuel tank.

    2nd: I replaced the fuel anti-siphon on top of the tank. There was a significant difference in the amount of spring pressure the new valve has. A couple if pics below.

    DSCF3452.jpgDSCF3457.jpgDSCF3458.jpg
    Last edited by harmsway; 02-19-2012 at 05:44 PM.
    Patrick
    '08 Mobius LS. 4 Blade OJ 13x13 Prop.
    Kenwood KMR440U & RC107MR, T600-2 Rockford Fosgate powering 2 Liquid Acoustics 8" HLCD, Kicker SKM10 subwoofer
    5 light- light bar.

    Live life today!

  9. #9
    Join Date
    Oct 2010
    Location
    Pittsboro, NC
    Posts
    327

    Default 1st Attempt to fix hesitation issue

    Changing the fuel filter set up.
    3rd: I replaced the existing in line fuel filter with a spin on water seperator. The original in line filter was about 8" above the fuel tank, so the fuel was being sucked up hill.
    DSCF3453.jpgDSCF3454.jpgDSCF3462.jpg

    I located the new filter as low as I could get it and still be able to remove the spin on filter. I also allowed the new fuel line, going from the tank to the filter, to be slightly lower then the sipon valve. Almost like a pea trap.
    DSCF3464.jpgDSCF3463.jpg

    Now I just have to wait for about a month before I'll be able to get the boat back on the water.
    To be continued....
    Patrick
    '08 Mobius LS. 4 Blade OJ 13x13 Prop.
    Kenwood KMR440U & RC107MR, T600-2 Rockford Fosgate powering 2 Liquid Acoustics 8" HLCD, Kicker SKM10 subwoofer
    5 light- light bar.

    Live life today!

  10. #10
    Join Date
    May 2009
    Location
    Carlton Oregon
    Posts
    6,008

    Default

    Nice work man, i hope your catching this grimlen man. I know its been bugging you. I noticed at the end of last season i was getting some hesitation when i hit the throttle surfing, i am hopping just bad fuel filter, or cavitation of the prop as i know im finally maxing this prop out. I plan on a new prop this season as well.
    Malo <--- Means--Evil or Mean One. This explains a lot.
    2013 Mojo 2.5 Skylon Tower. Bestia < Beast >
    Exile ZLD
    6 SX65M Cabins
    6 XM9 Towers
    1 XI Big 15 Woofer in a custom Fiberglass box
    1 XI 1K Harpoon
    2 XI 800.4
    1 XI 2500.1
    2 Interstate 2400U 6V Golf Cart Batterties
    Custom 1 Off Evolution Cover

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •