Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2003
    Location
    Seattle
    Posts
    26

    Default mobius LSV ballast pump electric valve

    Brian, if you are out there could you tell me what is the brand(and model # if avaliable) of the electric ballast valves used in the 04 mobius lsv bertha 3 bag ballast system.
    I need to fix one and it is not pratical to go back to the dealer for a $20 repair(I hope)
    Thanks, kcjczrs@yahoo.com
    04 Mobius LSV w/320

  2. #2
    Join Date
    Sep 2006
    Posts
    32

    Default Replying to Topic 'mobius LSV ballast pump electric valve'

    Brian Raymond is at Indmar school this week. I'm sure you're wondering why he needs to go to school since he was practically born and raised in a boat . Anyway the only way you can get the electric valves is to order them through your local dealer. They could have it dropped ship to you and save you the drive.

    Regards,

    Jay Warren
    Mkt Manager

  3. #3
    Join Date
    Jul 2003
    Location
    Seattle
    Posts
    26

    Default Replying to Topic 'mobius LSV ballast pump electric valve'

    Brian, this is a repost from a couple weeks ago; if you could answer this question, it seems that Jay Warren was answering you e-mail and did not want to answer the question

    Brian, if you are out there could you tell me what is the brand(and model # if avaliable) of the electric ballast valves used in the 04 mobius lsv bertha 3 bag ballast system.
    I need to fix one and it is not pratical to go back to the dealer for a $20 repair(I hope)
    Thanks, kcjczrs@yahoo.com
    04 Mobius LSV w/320

  4. #4
    Join Date
    Aug 2002
    Location
    Maryville, Tn.
    Posts
    382

    Default Replying to Topic 'mobius LSV ballast pump electric valve'

    K-N-C, I apologize for the delayed response. What exactly are the symptoms that you are having? (A)Bag fills when system off and driving.(B)Bag fills to slow.(C)When turned on, pump runs but solenoid doesn't click.(D)Solenoid clicks, but pump doesn't run.(D)No power to switch(lights in switch cover do not illuminate when on fill or drain). Did this issue occur slowly, or everything was fine last time out? Please varify batt. voltage and ground at the affected solenoid and pump. Check the ballast fuse panel under the dash and make sure there are no blown fuses or loose connections. Please keep me posted. Brian Raymond

Similar Threads

  1. Ballast Pump
    By joe98684 in forum Service & Repair
    Replies: 4
    Last Post: 07-10-2008, 01:32 AM
  2. Ballast pump
    By Dannad in forum Service & Repair
    Replies: 7
    Last Post: 06-04-2007, 07:37 AM
  3. Ballast Pump
    By Dannad in forum Sales & Information
    Replies: 1
    Last Post: 05-22-2007, 05:32 PM
  4. ballast pump
    By TheBeeZ in forum Service & Repair
    Replies: 1
    Last Post: 07-31-2003, 09:51 PM
  5. Electric fuel pump
    By wdf in forum General Chat
    Replies: 3
    Last Post: 06-19-2003, 10:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •