Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2009
    Posts
    2

    Default Reset check engine light???

    The CEL in my 07 xlv have been on for a few trips...everything seems ok...ie runs goods, gauges check ok. Is there a way to reset it? I tryed disconneting batteries but that did not reset it.

  2. #2
    Join Date
    Oct 2007
    Location
    Panama City Florida
    Posts
    1,798

    Default

    One simple check is to make sure your oil dipstick is seated all the way in! We had a check engine light on once and that was what created it! We had just checked the oil and didn't push the dipstick in good enough to seal.

  3. #3
    Join Date
    Jun 2007
    Location
    Calgary Alta Canada
    Posts
    887

    Cool

    I recently went through this as well. I was under the understanding it might correct itself after 6-8 full engine hot /cold cycles. Apparently some model have this. My engine light came on at first startup after dewinterizing,and it really bothered me at first as i thought i had done something wrong. After many conversations and inquiries ,i got numerous answers.
    I did know my boat was running fine, oil pressure was good ,temp was good etc and no apparent reason. Gas cap was tight , dipstick you name it.
    I even had a reply from engine nut,The motor guru.
    Only real reply was watch everything and run as is, or PAY and have it read by dealer and have it reset.
    It bothered the crap out of me ,and i even considered covering with tape and then low and behold my light went out.
    Since then i was asking another dealer tech and he said it mayhave even been a low battery sensor at first fireup even though i charged it up beforehand.

    I feel for you and now i still pay particular attention to how she runs but for now All is Good. Hope your luck changes and your light goes off as well.

  4. #4
    Join Date
    Jul 2009
    Posts
    2

    Default

    took it out this time and "poof" it was gone.....might have been the low battery....have to make sure its fully charged before i drive it from now on.

  5. #5
    Sled491 Guest

    Default

    We had the same thing this beginning of the season, and like most it just went away.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •