Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Jul 2009
    Location
    Nor Cal
    Posts
    80

    Default Another stereo question

    So I am going to begin fixing up my repo over the winter, not sure I'll be "done" by next season, alot to do, and I will probably post several more times with questions as I go but I'll start with the stereo.

    I am going to try and pick up six of the DB651's while they're still on sale, looks like I'd be an idiot not to. I have the white Aeware remotes on the console and stern. Its not had a stereo in it since Ive had it so I'm not positive they even work but thought I'd get a compatible deck on the chance they do. I did some research and found somewhere any Kenwood marine deck model # ending in MRCC would work w/the remotes, but looks like some posts here indicate others, including non-marine decks, would also work. I'm dont absolutley have to have a marine as mine would be in the "glove box" though I like the idea of water resistance, though not at the price of performance. So, long way of saying I'm looking for deck recommendations and an opinion as to if I can get a quality compatible deck or should I look at replacing the remotes as well?

    And one last probably stupid question; The boat will have six speakers but all decks seem to be 4 channel; so how do I hook up to all six speakers w/o using an amp? Or do I?

    2005 Outback; stripped for now.

  2. #2
    Join Date
    Dec 2006
    Location
    Tigard, Oregon
    Posts
    3,016

    Default

    wannabe,

    Go to sonicelectronix.com and search the Kenwood KDC-MP638U head unit. At $130, this is the cheapest Kenwood HU they carry that is compatible with the factory remotes. The key is the light blue wire comimg out of the back of the chassis as seen in the pic below. It is labeled "Remo Cont" (hard to see in this pic but it's easy to see on the pics of the other more expensive Kenwoods) and this is the wire that you need to connect the remotes to. If it doesn't have this wire, then it's not compatible with the factory remotes.

    I bought a similar model (Kenwood eXcelon KDC-X692) that is now discontinued. I would personally go with the Kenwood KDC-MP442U for $10 more as it has aux and USB inputs on the front. Like the KDC-MP638U, it also has 3 pairs of 4V preouts which is important if you decide to add amps down the road.

    As far as wiring your 6 speakers to the 4 channels on the head unit, just do what the factory does - wire the 4 rear speakers in parallel to the rear channel and wire the front speakers to the front channel.

    Also, I don't see why your white Aeware remotes wouldn't work - I haven't heard of any of them going bad.

    Good luck with the project.

    Al

    Last edited by cab13367; 10-25-2009 at 11:21 PM.
    Al

    2006 Mobius LSV

  3. #3
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,164

    Default

    sounds like you are on the right path.
    not sure of your intentions for the stereo and how much listening you will do, but I would recommend adding an amp. even if it's a small 4ch, the sound quality from the polks will be 10x better than the deck amp.
    if you don't plan on using them much, the probably not needed, but if you do like to park and listen to tunes, spend the money and do it once the first time.

    good luck and keep posting progress...
    '06 Supra Launch 20SSV-gone but never forgotten

  4. #4
    Join Date
    Jul 2009
    Location
    Nor Cal
    Posts
    80

    Default

    Thanks for the help! That website is very informative. Looks like the KDC-X692 is now X693. I think I would do at least the MP442U but the eXcelon X493 and X693 are all within $25 of each other and have the blue remote wire, so I'm thinking the eXcelon version is probably worth the little extra $?

    I dont know that I'll do an amp right away with everything else I have to do but may down the road. I'm not a huge stereo person but I do like it to sound good. I agree with doing it once the first time, but will probably have to wait until some other priorities are addressed. It has a sub box already in the boat and I may put some speakers on the tower (after I get a tower) so may be the time to enhance the system then. I will update on the progress for sure!

    Thanks for the help!

  5. #5
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,164

    Default

    I don't remember all the differences, but I thought the excelon series has a higher preout voltage. a good thing if you are going to drive amps, unneeded if you are not. I have a mid-grade excelon in my truck that has performed very well.
    '06 Supra Launch 20SSV-gone but never forgotten

  6. #6
    Join Date
    Aug 2009
    Location
    Montana
    Posts
    2,265

    Default

    Al,
    I'm looking to upgrade my HU and use the existing Aeware remote as well (and maybe add a transom). I thought the blue remote wire had something to do with the wireless remote that they are all pictured with? Here's a pic of the back of my existing stock unit.100_5881.jpg100_5882.jpg

    Quote Originally Posted by cab13367 View Post
    wannabe,

    Go to sonicelectronix.com and search the Kenwood KDC-MP638U head unit. At $130, this is the cheapest Kenwood HU they carry that is compatible with the factory remotes. The key is the light blue wire comimg out of the back of the chassis as seen in the pic below. It is labeled "Remo Cont" (hard to see in this pic but it's easy to see on the pics of the other more expensive Kenwoods) and this is the wire that you need to connect the remotes to. If it doesn't have this wire, then it's not compatible with the factory remotes.

    I bought a similar model (Kenwood eXcelon KDC-X692) that is now discontinued. I would personally go with the Kenwood KDC-MP442U for $10 more as it has aux and USB inputs on the front. Like the KDC-MP638U, it also has 3 pairs of 4V preouts which is important if you decide to add amps down the road.

    As far as wiring your 6 speakers to the 4 channels on the head unit, just do what the factory does - wire the 4 rear speakers in parallel to the rear channel and wire the front speakers to the front channel.

    Also, I don't see why your white Aeware remotes wouldn't work - I haven't heard of any of them going bad.

    Good luck with the project.

    Al



    2007 Moomba Outback - waiting for summer!

    Why Not? Play Hard! Get wet

  7. #7
    Join Date
    Dec 2006
    Location
    Tigard, Oregon
    Posts
    3,016

    Default

    Quote Originally Posted by viking View Post
    Al,
    I'm looking to upgrade my HU and use the existing Aeware remote as well (and maybe add a transom). I thought the blue remote wire had something to do with the wireless remote that they are all pictured with? Here's a pic of the back of my existing stock unit.
    viking,

    Your thumbnail pics are too small for me to see anything and a larger pic does not come up when I double click on the thumbnails.

    The light blue wire labeled "remo. cont." is for cars with audio controls on the steering wheel (and also works with the remote control pucks on our boats) - it has nothing to do with the wireless remote that comes with the head units.

    Adding a second remote is easy - just splice into the existing wires at the current remote and run it back to the second one.

    Al
    Al

    2006 Mobius LSV

  8. #8
    Join Date
    Dec 2006
    Location
    Tigard, Oregon
    Posts
    3,016

    Default

    viking,

    I can see the larger pics now. Had to right click on the thumbnail then open. Anyway, on the stock head units, the wire for the remotes is the one just to the right of your black RCA connector. That serves the same function as the light blue "remo cont" wire on the other Kenwoods.

    Al
    Al

    2006 Mobius LSV

  9. #9
    Join Date
    Aug 2009
    Location
    Montana
    Posts
    2,265

    Default

    Thanks Al,
    I thought that was it but wasn't 100% sure. Sorry the pics I uploaded were crap but took them in a hurry while trying to watch my 4 and 2 yr old rearrange my house
    2007 Moomba Outback - waiting for summer!

    Why Not? Play Hard! Get wet

  10. #10
    Join Date
    Jun 2008
    Location
    De Pere WI
    Posts
    4,164

    Default

    are you positive that any other kenwood deck will work with the pucks?
    there isn't a connection on the back of the one pictured above for the pucks to plug into and all the info I see online states it must be a marine deck??
    '06 Supra Launch 20SSV-gone but never forgotten

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •