Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2009
    Location
    Tacoma WA
    Posts
    71

    Default speaker not getting full power?

    2008 mobius lsv.... stock kicker speakers.. hooked up to the amp etc,.. recently ive been noticing that the right side cabin speakers work, but the sound is very quiet, no where near the left side,, yet if you turn it up real loud they begin to sound like a fuzzy mess. (and yes i have checked the speaker balance on our deck) ive taken the speakers out, looked at all connections from the amp to the connections to the actual speakers and cant figure it out any suggestions?

  2. #2
    Join Date
    Apr 2008
    Location
    California
    Posts
    2,840

    Default

    Could be the amp itself. Take it to an audio shop and have the amp checked.
    2007 Mobius LSV

  3. #3
    Join Date
    May 2009
    Location
    Dallas, TX
    Posts
    880

    Default

    Alex,

    If you want to do some easy diagnosis you can narrow down the culprit and usually without even a multimeter, although its a great tool for these situations.

    While you may have the exception here, its generally pointless to proceed with any diagnosis without first checking the voltage.

    Start by physically checking the security of all connectors, particularly the tightness of the RCA outer shield sleeve and amplifier speaker terminals. Alot of problems can be induced by vibration over time, especially in a towboat. Its possible for a bad or resistive contact to not misbehave at lower levels but suddenly appear as you add a little current.

    Reverse the RCAs at the source, then at the amplifier input. You're looking for the issue to transfer to the other side. Similarly, reverse the channels on the speaker wires at the amplifier outputs. Then, if need be, run jumpers directly to the speakers or remove and reverse the left and right speakers.

    One speaker with a marginal voice coil can affect that entire amplifier channel so check each speaker independently.

    Gently push in on the cone of the problematic speakers with equal side to side pressure. See if you feel or hear the voice coil rubbing or dragging within the gap. Also, listen to see if the speaker momentarily stops playing as you gently push in on it.

    By a simple process of elimination you will isolate the cause.

    And as Razzman said, if you think its the amplifier, have it bench checked at a shop first before replacing it. Plus, you don't want to introduce a new amplifier into an old problem.

    Hope this helps.

    David
    Earmark Marine

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •