Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2004
    Posts
    20

    Default Engine Died (No Power)

    This past weekend my wife some friends and I were heading out for a day of wakeboarding and skiing. On the way out we were going about 15-18 mph and our boat just DIED. I went into panic and started troubleshooting, to no avail I could not fix it on the water. We got the boat back to the dock and had a mechanic look at it, he said that we were not getting any power to the starter. He could get the engine to turn over by bypassing the ignition, but that is it. We have had a litany of problems with our 04 Mobius for the three months we have had it. We are happy with our boat, but man-o-live I would like to use my boat especially because it was brand new when we bought it. Has anyone else had these types of problems with their boats? I know the old addage about boats, but this is getting to be too much.

  2. #2
    Join Date
    Feb 2003
    Location
    ISLAND LAKE IL
    Posts
    142

    Default Replying to Topic 'Engine Died (No Power)'

    bluoval,
    Take a second and look at the back of the engine is it a DD Mobius or V drive ? If it is a dd there is a large connector on the back side that is known to come loose at least in 02 vintage and boat would just die as you are going. its about three inches around and is a multipin plug kind of hard to miss. Hope this helps.

    chris
    CS

  3. #3
    Join Date
    May 2004
    Posts
    5

    Default Replying to Topic 'Engine Died (No Power)'

    I had a simular problem. I found that one of the plugs that is connected to the circuit board behind the Switches in the dash. The main power came unpluged and stopped the motor and I couldn't do anything. Look under the dash and see if there is any unpluged wires.

  4. #4
    Join Date
    Jun 2002
    Location
    Lake Mayo NC
    Posts
    186

    Default Replying to Topic 'Engine Died (No Power)'

    There is also a main breaker mounted behind the observer seat, mine got tripped by accident and I had to reset it.

  5. #5
    Join Date
    Apr 2004
    Posts
    20

    Default Replying to Topic 'Engine Died (No Power)'

    Thanks for the feedback guys, but I have checked all of these things. The reset on the battery was tripped due to a surge in the system somewhere. The connectors behind the dash were also checked, but nothing was found disconnected.

Similar Threads

  1. Boat Died 3x
    By dtlaine in forum Service & Repair
    Replies: 3
    Last Post: 08-03-2007, 07:59 AM
  2. power turns
    By qb12 in forum General Chat
    Replies: 19
    Last Post: 05-24-2007, 01:30 PM
  3. 07 XLV or LSV....Enough power?
    By av8r in forum Sales & Information
    Replies: 3
    Last Post: 11-05-2006, 03:28 PM
  4. First time out, engine died on me!!
    By mase9921 in forum Service & Repair
    Replies: 18
    Last Post: 08-07-2006, 12:04 PM
  5. Tower speakers died over winter
    By Livindadream in forum General Chat
    Replies: 1
    Last Post: 05-20-2004, 08:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •